Notícia: Atualização necessária para libarchive recente

O algoritmo de compactação zstd traz compactação e descompactação mais rápidas, mantendo uma taxa de compactação comparável com xz. Isso irá acelerar a instalação de pacotes com pacman, sem mais inconvenientes.

O lançamento iminente do pacman 5.2 traz ferramentas de compilação com suporte para compactar pacotes com o zstd. Para instalar esses pacotes, você precisa do libarchive com suporte ao zstd, que entrou nos repositórios em setembro de 2018. Para que os pacotes compactados do zstd sejam distribuídos, precisamos que todos os usuários tenham atualizado para pelo menos libarchive 3.3.3-1. Você teve um ano, então esperamos que você já tenha atualizado. Apresse-se se não tiver.

Se você usa scripts personalizados, verifique se eles não dependem de extensões de arquivo codificadas. A extensão do arquivo zstd será .pkg.tar.zst.