Notícia: Puppet 4.0 entrou no [community]

Puppet 4 foi disponibilizado e quebra compatibilidade com a versão 3. Portanto os usuários precisarão atualizar o servidor para o Puppet 4 antes de atualizarem seus clientes. Observe que se tiver apenas o servidor Puppet 4 disponível, os clientes Puppet 3 não irão funcionar. Os locais para as algumas coisas também mudaram incluindo as configurações, manifestos e arquivos de módulos. Você precisará seguir as instruções de atualização para seus servidores e clientes:

URL da notícia: https://www.archlinux.org/news/puppet-40-enters-community/