Bem-vindo ao Arch Linux Brasil!

O Arch Linux Brasil é um projeto formado por usuários brasileiros da distribuição Arch Linux, que tem como maior objetivo divulgar e tornar o Arch Linux mais próximo e acessível para os brasileiros.

Para isso criaremos novos documentos em nosso idioma, tiraremos dúvidas, realizaremos eventos e, é claro, trocaremos muitas idéias.

Caso você ainda não conheça o Arch Linux, você pode ler mais sobre ele clicando aqui. Mas se já conhece e deseja participar de nossa comunidade, cadastre-se em nossa lista de discussão, no fórum e visite o nosso canal no IRC. :-)

Se você quiser dar sugestões e/ou fazer críticas sobre o andamento do projeto, por favor envie um e-mail para contatoΘarchlinux-br.org.

Últimas notícias (mais)

RSS Feed

Novos pacotes de kernel e hooks de mkinitcpio

10 de Novembro de 2019

Todos os nossos kernels oficiais (linux, linux-lts, linux-zen e linux-hardened) não mais instalam o kernel em si no /boot.

A instalação é feita por hooks e scripts do mkinitcpio, além de remoções. Não há necessidade de qualquer intervenção manual.

A intenção é tornar os pacotes do kernel mais independentes, além de tornar o processo de inicialização mais flexível, além de mantê-lo compatível com versões anteriores.

A partir de agora, apenas o mkinitcpio possui hooks para ...

Esclarecimento a cerca de atividade recente de e-mail na lista arch-announce

26 de Outubro de 2019

Hoje, um e-mail foi enviado para a lista de discussão do arch-announce tendo sido capaz de contornar as verificações da lista de permissões que são feitas pelo software mailman. Isso não ocorreu devido a acesso não autorizado e nenhum servidor Arch Linux foi comprometido.

Implementamos medidas para garantir que isso não aconteça novamente, usando o recurso de senha de publicador do mailman. Também garantimos que essas verificações simples da lista de permissões não sejam usadas ...

Atualização necessária para libarchive recente

16 de Outubro de 2019

O algoritmo de compactação zstd traz compactação e descompactação mais rápidas, mantendo uma taxa de compactação comparável com xz. Isso irá acelerar a instalação de pacotes com pacman, sem mais inconvenientes.

O lançamento iminente do pacman 5.2 traz ferramentas de compilação com suporte para compactar pacotes com o zstd. Para instalar esses pacotes, você precisa do libarchive com suporte ao zstd, que entrou nos repositórios em setembro de 2018. Para que os pacotes compactados ...

Grupo "base" substituído pelo pacote obrigatório "base" - requer intervenção manual

6 de Outubro de 2019

O grupo base foi substituído por um metapacote com o mesmo nome. Nós aconselhamos que os usuários instalem esse pacote (pacman -Syu base), pois ele é efetivamente obrigatório a partir de agora.

Espera-se que os usuários que solicitam suporte estejam usando um sistema com o pacote base.

Adendo:
Esteja ciente de que o base como está atualmente não contém:
- Um kernel
- Um editor
... e outros softwares que você pode estar interessado. Você precisará instalá-los separadamente ...



Atualização do astyle>=3.1-2 requer intervenção manual

26 de Agosto de 2019

O pacote astyle anterior à versão 3.1-2 não possuía um link de soname. Isso foi corrigido em 3.1-2, então a atualização precisará sobrescrever o link de soname não rastreado criado pelo ldconfig. Se você receber um erro

astyle: /usr/lib/libastyle.so.3 existe no sistema de arquivos

ao atualizar, use

pacman -Suy --overwrite usr/lib/libastyle.so.3

para realizar a atualização.

Atualização do tensorflow>=1.14.0-5 requer intervenção manual

21 de Agosto de 2019

Os pacotes de tensorflow anteriores à versão 1.14.0-5 não tinham alguns links de soname. Isso foi corrigido na 1.14.0-5, portanto, a atualização precisará sobrescrever os links de soname não rastreados criados pelo ldconfig. Se você receber um erro assim

tensorflow: /usr/lib/libtensorflow.so.1 existe no sistema de arquivos
tensorflow: /usr/lib/libtensorflow_cc.so.1 existe no sistema de arquivos
tensorflow: /usr/lib/libtensorflow_framework.so.1 existe no sistema de ...

Atualização do libbloom>=1.6-2 requer intervenção manual

11 de Julho de 2019

O pacote libbloom anterior à versão 1.6-2 não possuía um link de soname. Isso foi corrigido em 1.6-2, então a atualização precisará sobrescrever o link de soname não rastreado criado pelo ldconfig. Se você receber um erro

libbloom: /usr/lib/libbloom.so.1 existe no sistema de arquivos

ao atualizar, use

pacman -Suy --overwrite usr/lib/libbloom.so.1

para realizar a atualização.

Atualização do mariadb 10.4.x requer intervenção manual

27 de Junho de 2019

A atualização para o mariadb 10.4.6-1 e posterior altera o layout de configuração conforme recomendado pelo upstream.

O arquivo de configuração principal foi movido de /etc/mysql/my.cnf (e seu diretório include /etc/mysql/my.cnf.d/) para /etc/my.cnf (e /etc/my.cnf.d/) . Certifique-se de mover sua configuração.

Serviços instanciados (como [email protected]) não são mais configurados em arquivos separados (como /etc/mysql/myfoo.cnf). Em vez disso ...

Atualização do libutf8proc>=2.1.1-3 requer intervenção manual

14 de Julho de 2018

O pacote libutf8proc anterior à versão 2.1.1-3 tinha um link soname incorreto. Isso foi corrigido no 2.1.1-3, portanto, a atualização precisará sobrescrever o link soname não rastreado criado pelo ldconfig. Se você receber um erro

libutf8proc: /usr/lib/libutf8proc.so.2 existe no sistema de arquivos

ao atualizar, use

pacman -Suy --overwrite usr/lib/libutf8proc.so.2

para executar a atualização.

js52 52.7.3-2 atualização requer intervenção

17 de Maio de 2018

Devido ao SONAME da /usr/lib/libmozjs-52.so, não corresponder ao nome do arquivo, ldconfig criou um arquivo não rastreado /usr/lib/libmozjs-52.so.0. Isso foi resolvido e todos os arquivos estão presentes no pacote.

Para atualizar, remova /usr/lib/libmozjs-52.so.0 e prossiga com a atualização.

URL da notícia: https://www.archlinux.org/news/js52-5273-2-upgrade-requires-intervention/