Notícia: OpenVPN 2.4.0 atualização requer interação administrativa

Atualização para OpenVPN 2.4.0 realiza mudanças que são incompatíveis com as configurações anteriores. Tenha um cuidado especial se você depende de conectividade via VPN para acesso remoto! Interação administrativa é requerida:

  • Configuraçôes agora são esperadas no subdiretório. Mova seus arquivos do /etc/openvpn/ para /etc/openvpn/server/ ou /etc/openvpn/client/.

  • O caminho de busca do plugin mudou, remova o plugins/ extra do caminho relativo.

  • A unit do systemd [email protected] foi substituída pelo openvpn- [email protected] e [email protected]. Reinicie e reative conformemente.

Isso não afeta a funcionalidade do networkmanager, connman ou qopenvpn.